最完美的程序化系统带你创造10年稳赢
返回首页
量化投资,高频交易,程序化交易学习必备~900+个(200G+)培训视频持续更新中!!!
当前位置: 主页 > 海龟交易 >

海龟交易系统公式

时间:2009-12-23 21:22来源:未知 作者:admin 点击:
{公称名称: 海龟交易系统}

  {公称名称: 海龟交易系统}

  input:N1(55,6,99),N2(20,2,99);

  LC:=REF(CLOSE,1);

  TR:=MAX((HIGH - LOW),MAX((HIGH - LC),(LC - LOW)));

  ATR:=SMA(TR,20,1);

  AA:=(HHV(HIGH,N1) - (2 * ATR));

  BB:=CROSS(CLOSE,REF(HHV(HIGH,55),1));

  SSS:=CROSS(MIN(MA(CLOSE,13),AA),CLOSE);

  BBB:=BARSLAST(BB);

  SSSB:=BARSLAST(SSS);

  B1:=((BBB = 0) AND (REF(SSSB,1) < REF(BBB,1)));

  B1B:=BARSLAST(B1);

  B2:=((((BB = 1) AND (B1B < SSSB)) AND (B1B > 0)) AND (COUNT(BB,SSSB) < 3));

  B2B:=BARSLAST(B2);

  B3:=((((BB = 1) AND (B2B < B1B)) AND (COUNT(BB,SSSB) < 4)) AND (COUNT(BB,SSSB) > 2));

  B3B:=BARSLAST(B3);

  SS:=CROSS(MAX(AA,MA(CLOSE,13)),CLOSE);

  SS1:=(((SS AND ((B3B < B2B) OR (B2B < B1B))) AND (SSSB > B1B)) AND (COUNT(SS,B2B) < 2));

  SS1B:=BARSLAST(SS1);

  SS2:=((((SS AND (SS1B < SSSB)) AND (B3B < B2B)) AND (SS1B > 0)) AND (COUNT(SS,B2B) < 3));

  SSSS:=(SSS AND (REF(SSSB,1) > REF(B1B,1)));

  DRAWICON((B1 = 1),(LOW - 0.1),1);

  DRAWTEXT((B1 = 1),(LOW - 0.25),'买1'),colorFF;

  DRAWICON((B2 = 1),(LOW - 0.1),1);

  DRAWTEXT((B2 = 1),(LOW - 0.25),'买2'),colorFF;

  DRAWICON((B3 = 1),(LOW - 0.1),1);

  DRAWTEXT((B3 = 1),(LOW - 0.25),'买3'),colorFF;

  DRAWICON((SS1 = 1),(HIGH + 0.1),2);

  DRAWTEXT((SS1 = 1),(HIGH + 0.25),'止损1'),colorFF00;

  DRAWICON((SS2 = 1),(HIGH + 0.1),2);

  DRAWTEXT((SS2 = 1),(HIGH + 0.25),'止损2'),colorFF00;

  DRAWICON((SSSS = 1),(HIGH + 0.1),2);

 

  DRAWTEXT((SSSS = 1),(HIGH + 0.25),'快卖'),colorFF00;

(责任编辑:admin)
量化投资,高频交易,程序化交易学习必备~900+个(200G+)培训视频持续更新中!!!
------分隔线----------------------------
云量化商城
如果您会开发策略,请进!大量项目等待与您合作!
推荐内容
量化投资培训